assign won\t launch with or without a project


Yesterday (3/10/2021) my ccpn v3.0.3 running in Mac Mojave was working.  Today it starts to launch and then fails.  I HAVE NOT updated my system software  I tried restarting my machine and also tried launching with or without a project.  If I give it a project name, it opens some of my windows, but then returns with a pop-up with the Exception error and then fails.

Can you help me get back to a functional state?  I`m attaching a text file with the Traceback from the X window.

Many thanks,
Mary Starich

Hi Mary,

this looks as though there is some problem connecting to the server. Try disconnecting your computer from the internet and then starting the program (which it should do) and then you can go to Preferences and uncheck the `Verify SSL certificates` option.

In future we shall make sure that you can start without a server check from the command line, but for the time being you will have to disconnect fully if `Verify SSL certificates` is checked.

Hopefully this will fix things.

Best wishes,


Hi Vicky,

Thank you for the fix.  I`m up and running.  Since a recent widespread hack, my organization has made numerous changes to our IT security in the background.  It could be that something was pushed to my machine which blocked the connection.