Black windows

Good afternoon, 
Following the download of the software, I arrived to open my spectra. 
Now when I try to open it all the window become black. I have still the different part of the sidebar and the menu bar when I click in their location on the window but it is impossible to assign. 
Thank you for your help, 


Hi Morgane, before going in more complex solutions, can you try just to resize the window with the mouse from a corner.

Hey LucaM
I have the same problem as Morgane. When I open a spectrum the window turns black. I can still interact with everything, but I can`t see anything. For me, this happened after I downloaded the new Licence file that was released yesterday, if that is any help.

Hope anyone has a solution.


Luca says he sometimes gets this when he unplugs his laptop from a high res display and then connects it to one at lower res. The problem solves itself when resizing the window. Does resizing work for you, or is this something else?


Hi Morgane
The new licence shouldn`t have any effect on the screen.

This looks like an issue caused by different flavours of Linux.
The current download was built under CentOS7 and your screenshot looks more like Ubuntu.

3.0.1 is almost ready, I`ll make sure that there is at least a CentOS7 and an Ubuntu version for download.


I seem to have the same problem that when I open any projects, all windows go black. Resizing doesn`t help.

For one project (but not others) the error below appears.

Traceback (most recent call last):
  File `/home/annemette/progs/ccpnmr3.0.0/src/python/ccpn/ui/gui/widgets/`, line 79, in _screenChangedEvent
  File `/home/annemette/progs/ccpnmr3.0.0/src/python/ccpn/ui/gui/widgets/`, line 87, in _screenChanged
  File `/home/annemette/progs/ccpnmr3.0.0/src/python/ccpn/ui/gui/lib/`, line 553, in refreshDevicePixelRatio
  File `/home/annemette/progs/ccpnmr3.0.0/src/python/ccpn/ui/gui/lib/OpenGL/`, line 849, in refreshDevicePixelRatio
    self.viewports._devicePixelRatio = self.devicePixelRatio()
AttributeError: `Gui1dWidget` object has no attribute `viewports`

Hope you can help,

Thanks for the fast response
In my case, I run CentOS7. As for resizing the window, nothing seems to work. I tried resizing the CcpNmr Analysis window, the CentOS7 window, and under different screen resolutions.
Any other ideas?

Okay, I found a solution to my own problem.
I normally run the VMSVGA graphics control with 3D acceleration on my virtual machine, but apparently that suddenly caused this problem. I switch over to VboxVGA without 3D acceleration and now it works.

Great! Thanks for sharing.


Another solution has been posted by Brian here: