Can't manage to open V2 project after looking through old forum posts

I have spent some time with the past V3 forum threads but still cannot manage to open my V2 project in V3 in order to extract peak lists and assignments left by a trainee in 2019.

I first just tried dragging and dropping the project folder. It looked promising, however, the terminal window just hung at the following message and nothing progressed in my ccpn window after 15+ minutes:

==> Getting user preferences
==> Language set to “English-UK”
==> Creating new, empty project
INFO : Located at /var/folders/40/nz7c_zv96j78cqz1p344jr2ch2qwxj/T/CcpnProject__24qt2yv.ccpn (Api.newProject:151)
==> Done, AnalysisAssign is starting
INFO : Handling urls… (GuiMainWindow._processDroppedItems:1187)

After this, I tried navigating to Plugins–>User Plugins–>Filter Labeled Mixtures and browsed to find my project folder. I could see all of the .xml files appear, grayed out. When I pressed the “Run” button, the following message appeared:

‘NoneType’ object is not iterable

I do not have the original spectra .ft2 files available in the path at this time, but I did not think that I needed these to be able to open the peak tables and assignments.

Can you assist in resolving this issue? Ideally, I’d like to be able to pull the spectra out of archive and look at the assignments on my hsqc.

Thank you,

Hi Mary,

it might be easiest if you send us the project to .
You are right that you don’t need to have the original .ft2 spectrum files to open the project.
A while ago, it took a long time to open large V2 projects in V3 (I think I had one which took a good 10 minutes to open), but that was with spectrum files and was due to the noise estimation routine which we’ve fixed now. Even a large project shouldn’t take more than a minute or two to load and should give you some sort of information.


Hi Mary,
I would follow Vicky’s advice on the sending us the project to check.
However, I have pushed a fix for the plugin so it shouldn’t give the TypeError.
The files are greyed-out because it doesn’t think it is a valid project, using a simple check whether the ‘memops’ folder is found on the correct place.
I have added a checkbox at the top to override this if you only want to check a sub-folder of your project.