Chemical Shift Mapping Module (alpha) not opening from the macros menu on W10

Hey :slight_smile:

I’m trying to do Chemical Shift Mapping using the CcpNMR macro.
When I run the macro nothing happens. I have both tried in empty projects, on my own data and on the project from the Chemical Shift Perturbation Tutorial.

When I open the macro script, line 5 shows an error message: [pyFlakes] 7 undefined name ‘application’.

I don’t know that much about macro writing or how to fix this problem, so I hope someone can help :cowboy_hat_face:

Hi Iben,

That’s interesting.
Which OS are you?
Can you open the python console using the short cut “space-space” or from View (main menu), then run the same command as the macro:


and if unsucessful, please share any traceback.


BTW, # [pyFlakes] 7 undefined name ‘application’ .
The warning next to application in the editor is because indeed application is not defined in the macro itself.
However the macro is run within the Interactive Python console Kernel, which has “preloaded” a set of built-in namespaces, such as “application”. Other namespaces available to use within a macro which not requires imports are:




You might want read more in our macro tutorials

We will amend the editor to reconigise the built-in namespaces and perhaps give a colour to be easily identifiable.

1 Like

Thanks for the quick reply,

I have Windows 10

I tried running the command directly from the python console and it worked! So thank you