error installing

this is the error I had when trying to download version 3.2
and this is what happened when I opened assign.bat
How can this be fixed?

Hi Miriam,

have you applied the Updates yet? There is a bug which should be solved if you double-click on update.bat first and install the updates before trying to run the program with assign.bat.


yes it worked.
now I am trying to open a project I have used before and it won’t open
this is the error
==> Getting user preferences
==> Language set to “English-UK”
INFO : Folder may be read-only, or may not exist (ProjectArchiver.archives:93)
==> Checking registration on server
==> Done, AnalysisAssign is starting
INFO : application.loadProject(‘C:\Users\drorimi2\Desktop\MSc\CCPNMR\SH3_all.ccpn’)
Error loading file for: <memops.Implementation.MemopsRoot id:2478485155952>
Reading: <_io.TextIOWrapper name=‘C:\Users\drorimi2\Desktop\MSc\CCPNMR\SH3_all.ccpn\ccpnv3\memops\Implementation\SH3_all.xml’ mode=‘r’ encoding=‘cp1252’>
Last xml tag read: None
Parser state was: reading
Current object was: []
WARNING: Error loading “C:\Users\drorimi2\Desktop\MSc\CCPNMR\SH3_all.ccpn”: XmlLoader.loadProject: ‘NoneType’ object has no attribute ‘url’ (Framework._loadV3Project:1304)


But sorry about the project error. Do you have a backup you can use? See our recent video on backups for how these work and how to restore:

Otherwise, I suggest you send your project (without spectra) to us at and we’ll take a look.