Exporting NEF - error

Hello,
sorry for the stupid question. I am trying to export a project as NEF, and I get this error:

RuntimeError: Spectrum.aquisitionAxisCode: this should not happen; more then one dimension defined as acquisition dimension

I went to all the spectra, looked into the dimensions, and checked the Axis codes. I set them according to the Structure Tutorial, and used the “Copy to Axis Codes” after selecting the Reference Experiment Dimensions option:

  • 13C noesy is Hc, Ch, H (in another Noesy I have: Cn, Hc, H)
  • 15N noesy is Hn, Nh, H (in another Noesy I have: Hn, H, Nh)
  • 13C HSQC is Hc, Ch
  • 15N HSQC is Nh, Hn
  • HNCA: Hn, CA, Nh

Can you please help me fixing this problem?

Thank you
Francesca

Hi Francesca,

I cannot replicate this issue in any of my projects.

I presume you have your 3.1.0.beta up to date? (you can run updates in terminal window: ./updates)

Feel free to send your project to us and would be great if you could include traceback from the terminal window.

Kind regards,
Eliza

Hi Eliza,
thanks for your reply!

I confirm you that I have all the updates. I also tried exporting from the laptop running on Windows, and I get the same error.
I guess I made some mistake in naming the axis, but I don’t know what to change into the spectra properties…

I now sent you the project and traceback at the email support@ccpn.ac.uk.

Thank you once more!
Kind regards,
Francesca

Dear Francesca,
Eliza sent me the project. The problem stems from the import of your NmrPipe HSQC, which is transposed and somehow it acquired a set of wrong parameters defining the acquisition along the way. There is any easy fix :slightly_smiling_face:
Open a console window (space-space or View–>Show Python Console from menu) and copy and execute the following line:

get(‘SP:hNGF_13C15N_HSQC_ccpn’).isAquisition = (False, True)

(translation: get the hsqc spectrum and set the isAquisition parameter to False for the N15 dimension and True for the 1H dimension)

The export to NEF should then work as advertised. Meanwhile, we’ll try to fix to code to avoid it in the first place from happening.

Cheers
Geerten

Dear Geerten,
thank you very much for your kind reply and apologies for the delay.

I have tried fixing the project according to your instructions, but unfortunately it is not enough to export the NEF. I tried both from linux and windows. I can only succeed if I deselect all the peak lists from the NEF exporting window.
I have also tried to apply the same script line to the other HSQCs, which were also processed in NMRPipe with the same script as your mentioned spectrum. But this did not work, too. I tried exporting the project by selecting only the peak lists of the noesys, but this did not work either.

I am really sorry - maybe I am doing something wrong…
I would be really grateful for any suggestion you might give me.

Thank you very much,
regards
Francesca

The issue with NMRPipe spectra flipping and exporting to NEF is now fixed.
Eliza

Dear all,

unfortunately, the same problem persists for all my by NMRPipe processed, >2D spectra.

Thank you.

Best,
Max

Hi Max,
I could solve the problem through the update of v3 this week, after the CCPN team pushed the updates to fix this problem.

Best,
Francesca

Hi Francesca,

thanks for your response! However, my ccpnmr3.1 is updated to the newest version and the error remains.

Is it necessary to “reload” all the spectra after updating? I would not like to do that since I do not want to loose my assignment progress.

Best,
Max

Hi Max,
in fact yes, I reloaded the spectra. However, I also did not want to loose the assignments, therefore I used the following trick.
I loaded each spectrum again. Then I copied every peak list of each “old spectrum” to the corresponding reloaded one, and after checking that it was fine, I cancelled the old spectrum. The new spectrum will have a “_1” tag at the end, which you can easily remove by renaming the spectrum after you finish the reloading.
There are probably easier and more clever ways to do this - I just tried this one and it worked for me. I had mainly HSQCs and 3D noesys in this project.
I would anyway suggest to save the project with a new name before starting this procedure, so that you can easily go back if something goes wrong.

Hope this helps!
Best,
Francesca

Hi Francesca,

thanks a lot! Your workaround works! However, once I set the “Reference Experiment Type” for the newly imported spectrum, it does not work anymore.

So for me it worked by 1.) reimporting the spectrum, 2.) copying the peak list, 3.) NOT setting the reference experiment type and 4.) finally exporting the nef file.

Thanks and best wishes,
Max

Dear all,

just a quick heads up: The above-mentioned solution works, but you have to add the

         _nef_spectrum_dimension_transfer.dimension_1
         _nef_spectrum_dimension_transfer.dimension_2
         _nef_spectrum_dimension_transfer.transfer_type
         _nef_spectrum_dimension_transfer.is_indirect

manually to the NEF file for the corresponding spectrum (since the reference experiment type information is not available). For example for my HSQC-NOESY, it looks like this:

      loop_
         _nef_spectrum_dimension_transfer.dimension_1
         _nef_spectrum_dimension_transfer.dimension_2
         _nef_spectrum_dimension_transfer.transfer_type
         _nef_spectrum_dimension_transfer.is_indirect

         1  2  through-space  false
         2  3  onebond  false
      stop_

Best wishes,
Max

Hi Max,

Thank you for your message.

This loop is defined by setting the experiment type. If project does not “know” which experiment it is, then magnetisation transfer cannot be written into the NEF file.

We are looking into the issue of NMRPipe spectra.

Kind regards,
Eliza

1 Like