Fatal Error Loading Project


I updated the Analysis Assign software this morning and had trouble with opening the program itself. I ended up having to delete folder and install from scratch. I was able to open the program as well as my project files to make sure they would open properly. I then quit the program and installed the updates. I was able to open the program but unable to open any of my project files. The error I am getting in terminal is the following:

==> Loading CCPN project `/home/dkhago/Documents/gp78C_spectra/gp78Cnew.ccpn`
INFO   : Closing /tmp/CcpnProject_qsrabhzm.ccpn/default                                                (Logging._info:109)
WARNING: Fatal error loading project: /home/dkhago/Documents/gp78C_spectra/gp78Cnew.ccpn - Reloading last saved position.    (GuiMainWindow._loadProjectLastValid:447)
INFO   : Closing /home/dkhago/Documents/gp78C_spectra/gp78Cnew.ccpn                                    (Logging._info:109)
==> Creating new, empty project
INFO   : Located at /tmp/CcpnProject_3jkr1qzq.ccpn                                                     (Logging._info:109)

Unfortunately, this is the second time that the fatal error message has happened to me and I am not quite sure why. I am going to reinstall the program again and see if I will be able to open my project. I am not sure if this information is useful or not but would there be any way to save my project file?


Turns out once I install the updates, my project files won`t open. If I don`t install the updates, I am able to open my project files.

So I seem to be having the same problem. I am unable to open up my project file, even after saving it before quitting the program. I had saved two versions of my project and I am unable to open both of them. The error message reads `Error loading project` and the following message appears in terminal:

==> Loading CCPN project `/home/dkhago/Documents/gp78C_spectra/gp78Cnew4.ccpn`
INFO   : Closing /tmp/CcpnProject_3vhrctdb.ccpn/default                                                (Logging._info:109)
Error loading file for:  <ccp.nmr.Nmr.NmrProject [`default`]>
Reading:  <_io.TextIOWrapper name=`/home/dkhago/Documents/gp78C_spectra/gp78Cnew4.ccpn/ccpnv3/ccp/nmr/Nmr/default+default_user_2019-05-29-08-02-03-195_00001.xml` mode=`r` encoding=`UTF-8`>
Last xml tag read:  _StorageUnit
Parser state was:  checking validity
Object stack was empty

I keep getting this problem and I am not sure as to how I am reproducing it. Last time, when I had updated the program, I received this error and so I just downloaded the program and reinstalled it. I had no updated it since and seemed to have this issue again. I reinstalled the program, but the problem seems to have persisted. Is there a reason why? Should I try to open my files on a Mac instead of Linux? I just don`t want to keep losing progress in my project files. Any help would be much appreciated!

Hi Domarin. Apologies for this error. We were able to reproduce this and Ed has just uploaded the newest release. Please reopen the same projects. If the same error occurs, we can try to retrieve your data as the last time you saved.

Hi Luca!

Thank you so much for responding! I tried to download and install again, but having problems opening the two project files from today. They are the same project, but at different save points as I was worried this sort of thing would keep happening. How should I send the project files to you?

Ok you can try to use the back file which automatically saved. Try this:
- Open the project.ccpn file and navigate > ccpnv3 > ccp > nmr > Nmr
- rename the file.xml to oldfile and remove the extension xml
- duplicate the file .xml.bak
- remove the extension .bak
Make sure the new .xml.bak and xml have the same names.

Try to run again. This should open the project. (without layouts)

So I my labmate and I tried and it still isn`t working. I think we are doing something wrong. Is it possible to email the file to you? Or maybe share it on dropbox?

Yes sure. Send a temporary link on ccpnmr3@gmail.com

Hi Domarin, just added a way to reopen a project which was compromised in some parts. It will load all the data and report the failed items. In your case only the ChemicalShift List was lost, but it can be easily recreated automatically. We are still investigating why this happened in the first place.
Please remove all the extra files in ccpnv3 > ccp > nmr > Nmr and keep only .xml.bak and .xml
Updates available soon.

Hi Luca!

Thank you! I also received the email with the recovered project file. Looks like I have everything there. The only problem I seem to run into is recreating the chemical shift list. I try to edit the list by adding the spectra from the `available` list to the `current` list. However, when I open up the chemical shift list module, I still am unable to see a list of chemical shifts. Is there anything else I need to check on before doing this?

Thank you again for all your help!

Hi, no CSL are auto-updated by default. I will check why is not recreating the list. Out of curiosity, if you export your project as NEF,(Menu>Project>NEF>export Nef File...) and then reload it, does the CSL reappear correctly? Thanks

Hi Luca!

For the recovered file you sent me, I tried exporting the file as .nef and then imported the same file. The chemical shift list does reappear correctly.

I was working on a different version of my project file an noticed that after saving and exiting the program, if I reopen the project file, the error problem still persists. I saw there were new updates and installed them (only 20 out of 23 were able to install). I am able to open the project file and see my spectra, the problem now seems to be that the chemical shift list is empty. The terminal message for this error is as follows:

==> Loading CCPN project `/home/dkhago/Documents/gp78C_spectra/gp78Cnew_3_2.ccpn`
INFO : Closing /tmp/CcpnProject_m96nd8qi.ccpn/default (Logging._info:109)
Error reading project ccp.nmr.Nmr.Shift.checkValid: resonance:
value cannot be None: <ccp.nmr.Nmr.Shift [`default`, 1, None]>
WARNING: Error initialising object <CL:default>. `NoneType` object has no attribute `serial`1 (AbstractWrapperObject._initializeAll:929)

So I try to export the project file as a .nef and am unable to do that. The file doesn`t seem to export properly. I have attached the appropriate terminal message. I hope this helps clarify.

INFO : project.exportNef(path=`/home/dkhago/Desktop/gp78Cnew_3_2.nef`, overwriteExisting=True, skipPrefixes=[], expandSelection=False, pidList=[`MC:A`, `CL:default`, `PL:CBCACONH_trosy.1`, `PL:CBCANH.1`, `PL:HaNCoN.1`, `PL:HNCA.1`, `PL:HNCACB_trosy.1`, `PL:HNCO.1`, `PL:NOESY_HSQC.1`, `PL:HSQC_HN_trosy.1`, `PL:HSQC_HN_after_CBCANH.1`, `PL:HSQC_HN_after_HaNCoN.1`, `PL:HSQC_HN_after_HNCO.1`, `PL:HSQC_HN_after_NOESY.1`, `PL:HSQC_HN_before_HNCA.1`, `PL:HSQC_HN_trosy_aftercbcaconh.1`, `PL:HSQC_HN_trosy_afterhncacb.1`, `PL:CBCACONH_XYproj.1`, `PL:CoN_2D.1`, `PL:HaCoN_2D.1`, `PL:HaNCoN_CO_Ny.1`, `PL:HNCO_projYZ.1`, `SU:gp78C.`, `NC:@-`]) (Logging._info:109)
Traceback (most recent call last):
File `/home/dkhago/Desktop/ccpnmr3.0.b5/src/python/ccpn/ui/gui/widgets/Action.py`, line 75, in <lambda>
self.triggered.connect(lambda checked, *args, **kwds: callback(*args, **kwds))
File `/home/dkhago/Desktop/ccpnmr3.0.b5/src/python/ccpn/framework/Framework.py`, line 1745, in _exportNEF
File `<decorator-gen-6>`, line 2, in exportNef
File `/home/dkhago/Desktop/ccpnmr3.0.b5/src/python/ccpn/util/decorators.py`, line 330, in theDecorator
result = func(*args, **kwds)
File `/home/dkhago/Desktop/ccpnmr3.0.b5/src/python/ccpn/core/Project.py`, line 902, in exportNef
File `/home/dkhago/Desktop/ccpnmr3.0.b5/src/python/ccpn/core/lib/CcpnNefIo.py`, line 931, in exportNef
pidList=pidList) #, exclusionDict=exclusionDict)
File `/home/dkhago/Desktop/ccpnmr3.0.b5/src/python/ccpn/core/lib/CcpnNefIo.py`, line 979, in convert2NefString
dataBlock = converter.exportProject(expandSelection=expandSelection, pidList=pidList) #, exclusionDict=exclusionDict)
File `/home/dkhago/Desktop/ccpnmr3.0.b5/src/python/ccpn/core/lib/CcpnNefIo.py`, line 1368, in exportProject
notes=self.notes, peakClusters=self.peakClusters)
File `/home/dkhago/Desktop/ccpnmr3.0.b5/src/python/ccpn/core/lib/CcpnNefIo.py`, line 1209, in exportObjects
File `/home/dkhago/Desktop/ccpnmr3.0.b5/src/python/ccpn/core/lib/CcpnNefIo.py`, line 1598, in chemicalShiftList2Nef
shifts = sorted(chemicalShiftList.chemicalShifts)
File `/home/dkhago/Desktop/ccpnmr3.0.b5/src/python/ccpn/core/_implementation/AbstractWrapperObject.py`, line 893, in _allDescendants
objs = self._getChildren(classes=[className])[className]
File `/home/dkhago/Desktop/ccpnmr3.0.b5/src/python/ccpn/core/_implementation/AbstractWrapperObject.py`, line 487, in _getChildren
for className, apiChildren in self._getApiChildren(classes=classes).items():
File `/home/dkhago/Desktop/ccpnmr3.0.b5/src/python/ccpn/core/_implementation/AbstractWrapperObject.py`, line 509, in _getApiChildren
for apiObj in childClass._getAllWrappedData(self):
File `/home/dkhago/Desktop/ccpnmr3.0.b5/src/python/ccpn/core/ChemicalShift.py`, line 140, in _getAllWrappedData
AttributeError: `NoneType` object has no attribute `serial`

I am not sure if this is also helpful, but these are the three updates that are unable to be installed, as per the terminal message provided:

Installing /home/dkhago/Desktop/ccpnmr3.0.b5/doc/static/AnalysisShortcuts.pdf
Could not install /home/dkhago/Desktop/ccpnmr3.0.b5/doc/static/AnalysisShortcuts.pdf: write() argument must be str, not None
Installing /home/dkhago/Desktop/ccpnmr3.0.b5/doc/static/AnalysisShortcuts.xlsx
Could not install /home/dkhago/Desktop/ccpnmr3.0.b5/doc/static/AnalysisShortcuts.xlsx: write() argument must be str, not None
Installing /home/dkhago/Desktop/ccpnmr3.0.b5/tutorials/AnalysisShortcuts.pdf
Could not install /home/dkhago/Desktop/ccpnmr3.0.b5/tutorials/AnalysisShortcuts.pdf: write() argument must be str, not None
0 updates installed, 3 not installed, see console for error messages

Ed was able to fix the updates issue. You can now download the missing updates.
Still working on the other issue although the cause should be fixed.
Can you export to Nef only the object you need like, peaklists, except for the chemical shift lists. Uncheck those. Then create a new project, load your spectra and import the Nef in. Project, NEF, import Nef File...

I am also having issues opening project files. I have tried copying the .bak file in ccpnv3/ccp/nmr/Nmr, but without success. I have also updated the program recently. The project was saved using the current, updated version.


It looks as though there have been a number of people struggling with opening project files. This is not something that we have ever encountered or been able to re-create ourselves.
If anyone does struggle with this, please send us your project to ccpnmr3@gmail.com and hopefully we`ll be able to work out what is causing this issue.