importing V2 project, assignments missing


I opened a v2 project, this worked and it didnt show any errors. It does not contain assignments, chain information etc. though.
Is there a way to fix this?


I’m surprised by this. Could you perhaps send us your V2 project (without spectra) to and we’ll take a look.

Hi Vicky,

I was wondering if you were able to help cmb resolve this issue? I am experiencing a similar problem in which a v2 project that I opened in v3 did not have the assignments listed.

Are assignments saved as a particular file type that I could manually transfer to the updated v3 project?

Thank you for any help you can offer,

Hi Nathan,

I had a look back at the correspondence with cmb and it turned out that I had been able to open the project without issues and that cmb had been trying to open the incorrect folder.

Version 2 projects are simply saved as a folder MyProject with subfolders called ccp, ccpnmr and memops. It is the MyProject folder which you should drag into V3. If you use a folder higher up (e.g. the folder that MyProject is in), then V3 will probably only read in your spectra (if they are also in a subfolder), but not the actual project.

If that doesn’t solve the problem, then send us the copy of your project and we’ll have a look for you.

Best wishes,

Hi, Vicky,
This is Tom Pochapsky, Nathan’s co-worker. I did get the chemical shift list to display (we were missing a macro in the downloaded V3, so with the update applied, we could see it, so at least the assignment information is definitely in there), but none of the peaks assigned using V2 are showing up in the loaded spectra.

Also, I would like to export the chemical shift table from CCPnmr to Excel so we have a copy of the assignments to date that aren’t dependent on having the program open. Is there an easy way to do this?
Tom Pochapsky

Hi Tom,

V2 Import
I’m wondering what you mean about not being able to see the peaks. Do you mean that you can’t see the contours or that the actual peak markers are missing? I suspect it is the former. Unfortunately, the contour levels get mangled when moving from V2 to V3 (I thought we had set it such that V3 simply resets them based on the noise, but perhaps that isn’t working?). So you could try changing the contour levels and seeing if that makes a difference. Or you could do TH to show a horizontal trace on the mouse as a quick way to see if the underlaying spectral data is accessible or not. Otherwise, VP (or Spectrum / Validate Paths) should show you the data file that each spectrum is linked to. If these are coloured red, then the paths are incorrect and you will have to correct them. Once they go green hopefully you can see the spectra.
If the issue is with the actual peaks, then probably the best thing would be to send us the project (without the spectra) and we’ll take a look at what is going on.

Export to Excel
On any table you can right-click and choose to export either just the visible columns or all columns (right-click on a column heading and go to Select Columns… to view/hide columns). You can then save the data in comma or tab separated format or in Excel format.

Best wishes,

Thanks, Vicky,
We have both issues; if we just dump the v2 project folder into the v3 window, the spectra open nicely with contours intact (after re-setting the paths), but the peak lists are empty. OTOH, if I open the V2 project from the “open project” dropdown, the peak lists are all there but the spectra are messed up, just noise no matter where I set the baseline or # of levels. I don’t suppose there is a way of exporting the peak list tables to some other format and then re-importing them? I tried “copy Pid”, but couldn’t find any way to paste into the peak list window.
Tom P.

Oh dear - how strange (but sort of also useful?) that you get different behaviour by loading the project in different ways - will have to investigate that!
Yes, you can easily export/import the peak lists - using NEF. Simply do EX and select what you want to export, then use IN to import again.
For information have a look at this tutorial:

My guess is with the contour levels is that you have to up them by several orders of magnitude - easiest from the CO pop-up box.


Aha. That works. I opened the spectra with the peak list intact, and reset the baseline to 10e6, and the peaks appeared. All better now! Thanks.
Tom P

1 Like

Another quick question. How do I move from a peak assignment in a list to actually seeing that peak in a spectrum? Is there a way to see which assigned peaks are contributing to the chemical shifts listed in the table?
Thanks, TomP

Hi Tom,

if you double-click on a peak in a peak table, then that should navigate to the peak in the spectrum (see the Peak Lists and Tables page for more info).

To look at which assigned peaks are contributing to the chemical shifts, the best things is to use the Assignment Inspector (AI or Assign/Assignment Inspector). This has a chemical shift list at the top and then below you get a list of all the NmrAtoms in the NmrResidue selected above along with a list of the all the peaks to which that/those NmrAtom/s are assigned:

And again double clicking on peaks should take you to them in the spectrum (you can select only to navigate in certain SpectrumDisplays in the Settings if you like).

Best wishes,