Incompatibility of projects between WSL and Native Linux

Hi everyone,

I was wondering if anyone noticed some incompatibility between projects built on Windows SubSystem Linux (WSL, Ubuntu 18.04 LTS) and native linux (Ubuntu 20.04 LTS).

In my case, I can open the project and manipulate spectra, but no data is showing up, neither the assigned peaks. I have to go back to native linux because of Aria and Cyana calculations (Aria Web doesn`t seem to work well for my particular use case) and I`m having trouble with this one.
Working on NMR spectra without the data showing up is kinda difficult ! Does anyone had a similar problem? By the way, updates are done on both systems.

I tried to save the project with the native linux and re-open it, it didn`t work yet. Opening in on WSL works like a charm.
Also, saving the project takes a long time, and I never experienced that on the WSL version.
I`ve sent multiple reports of errors during the process, playing with spectra. Opening new spectra do not help, no data is showing up which is strange.

Edit: it seems that I have broken analysis. Even without a project, I cannot see the data on any spectra! Am I lacking some libraries to show data?

Thanks for your help!


Hi everyone,

I found the solution, and it was simple. My build of Ubuntu 20.04 LTS was lacking a library called which is part of the package freeglut3. I just didn`t see the error at the start of the program analysis before. I`m blind!

By a simple

$ sudo apt install freeglut3

Now it works perfectly. I had this exact same problem when i tried an installation of 18.04 LTS. It could be nice if it was somewhere in the installation documentation!

Have a nice day !

Great that you managed to sort this - thanks for posting the solution!
Best wishes,