instalation in feren os (ubuntu 22.04 based distro)


I have been trying to install ccpnmr in Feren os (ubuntu 22.04 lts based distro).
After extracting the file (right now Ubuntu 16.04 version is available at the website) and opening the bin directory at the terminal I used the commands:

$ ./assign
$ ./update

Unfortunately, instead of the program it seems that python3 is running.

Furthermore, I tried to run:

$ bin/assign

while I had opened the ccpnmr3.1.1 directory at the terminal. The following error popped up:

ccpnmr3.1.1/bin/lib/CcpNmrAnalysis: line 1: …/…/miniconda/bin/python: No such file or directory

I tried to navigate through the directories but everything seems to be fine.

I can confirm that I had the same problem with the ubuntu 22.04 version of the software a couple of months ago.

Do you have any idea what the problem might be?

Thank you in advance!




sorry not to have got back to you sooner.

We’re unsure what is going on here, as all the required files should certainly be there in our distribution. Are you using any symbolic links anywhere? If you are trying to run this from a directory that is symbolically linked then you might end up tying yourself in knots.
Perhaps best to open a generic terminal and then navigate to the ccpnmr3.1.1/bin directory before running ./assign rather than trying to open the ccpnmr3.1.1/bin directory from a file browser??

On the whole, I would also recommend that you use our 22.04 distribution, as we’ve had people using Ubuntu 22.04 who haven’t been able to run Analysis successfully with the 16.04 distribution.