No NmrPipe template defined

Dear All, I just updated to v3.1.1 (linux version) and I am having trouble to read 2D planes from a 3D processed with NMRPipe (the header was changed to a 2D). I got the following error message: “No NmrPipe template defined, in spite of 129 files comprising the 2D”. Is there an easy way to solve this? Thank you.


it’s slightly unclear to me what you are trying to do here. Did you manually change the header? If so, I suspect Analysis won’t like this, as it probably does various checks and has found an inconsistency between the header and the rest of the file.

Were you not able to drag some of the plane files in directly without modification?
Is this something you had done before which worked, but now doesn’t? If so, in which version did it work? I think the main changes to the data loaders happened when we moved from 3.0.4 to 3.1.0.
Geerten did most of the work on this. So if you give us some more details of what files you were trying to open and what modifications you were making, I can perhaps see if Geerten can find time to look at this.
It would also be helpful to understand why you need to look at the planes separately rather than as a 3D? Is this a pseudo-3D dataset?


Hi Vicky,

I am trying to read one plane from a CEST experiment that was processed with NMRPipe as a pseudo-3D. I changed the header to eliminate the third dimension with sethdr -ndim 2. Version 3.1.0 reads it fine, but after updating to 3.1.1, it does not read anymore and complains that there is not a NMRPipe template defined.
I agree that it is a bit strange since I am able to read other 3D planes that were processed in a similar way.


Hi Roberto,

without Geerten around at the moment and no test data it’s hard for us to work out what is going on here - clearly something in the import routine has ben tightened up.

I think for the moment the easiest thing would be to read in your pseudo-3D into the program. You can put this into a SpectrumDisplay and navigate through the planes if you simply want to look at them.
If you want to start picking peaks etc., you will need to right-click on the spectrum in the sidebar where you should be offered the option to Split Planes to SpectrumGroup. This will basically split your 3D into a set of 2Ds and place them all in a SpectrumGroup. This will write new data to your disk (.ndf5 files), but you can get rid of any planes you are not interested in.
Not massively elegant, but our current way of dealing with pseudo-3Ds.

If you are interested, I think @LucaM has a macro he wrote for someone looking at CEST data which will extract 1D slices from pseudo-3D datasets. I’m sure he’d be happy to share it.

Best wishes,