no peak picking in HCCH-TOCSY

I can not pick peaks in the hCCH- and the HcCH-TOCSY when I set the preferred dimension order to C C_3 H or H_3 H C respectively.


I’ve just tried this out with both an hCCH- and an HcCH-TOCSY just now and don’t seem to have any problems. I was able to pick peaks in the default orientation (H H_3 C and H C C3). I then did shortcut XY on the HcCH-TOCSY, and also tried changing the preferred dim order to H_3 H C. In all cases I was able to pick peaks without problems.

One thing that can sometimes happen in 3Ds it that the peak is slightly off the plane you are currently in and then the peak doesn’t get picked. Setting the plane count to 3 is something that can often help with this:

Screenshot 2023-03-02 at 14.09.09

Were you able to pick peaks before changing the dimension order?


Hey Vicky,

I can pick peaks in all different dimension orders.
Only in these two it is not working.
The peaks are also not in a different plane and no new peaks are added to the peaklist.
If I make XY and pick it there everything works.
I really have no idea.

(The pick and assign module is still working just not the manual peak picking by mouse)

Perhaps to start with it might be worth checking what is going on in the Python Console (I’m assuming you aren’t getting any errors in the terminal window?)

Could you open the Python Console (press the Space bar twice) and have a look at what is echoed in the top part? It should show the region picked and the order of the different dimensions should match that in the display:

I guess otherwise it could be an issue that the fitting isn’t working correctly. Are you able to place peaks? Shift+Ctrl/Cmd+click (rather than drag)? What happens when you then do SE (snap to extremum) and RP (refit peak)? Do these things work?

Both Shift/Cmd+click and drag do not work.

In the console I get the same message but only after the xy flip I get a peak in the peaklist.

mainWindow.newSpectrumDisplay(‘SP:hCCH’, axisCodes=(‘C’, ‘C_3’, ‘H’), stripDirection=‘Y’, position=None, relativeTo=None)
get(‘GS:3D_CCH.1’).createPeak(ppmPositions=[36.64766762405634, 28.58973754197359, 2.8708330822034385])
get(‘GS:3D_CCH_1.1’).createPeak(ppmPositions=[46.99140605330467, 29.252664528787136, 2.8708330822034385])

I’ve pushed an update, hopefully all working again

it is working now :)
thank you