NotImplementedError: Platform does not define a GLUT font retrieval function

Hi, I have installed v3.1.0 in my fedora36 system. I have aliased it to “assign” in .chsrc file. I am encountering the following error when executing “assign” in the terminal. Help me with this. Thank you.

Program licence (non-profit) valid until Mon Jan 4 07:34:08 2100
Traceback (most recent call last):
File “/home/nmrware/ccpnmr_new/ccpnmr3.1.0/miniconda/lib/python3.8/”, line 193, in _run_module_as_main
return _run_code(code, main_globals, None,
File “/home/nmrware/ccpnmr_new/ccpnmr3.1.0/miniconda/lib/python3.8/”, line 86, in _run_code
exec(code, run_globals)
File “/home/nmrware/ccpnmr_new/ccpnmr3.1.0/src/python/ccpn/AnalysisAssign/”, line 31, in
from ccpn.AnalysisAssign.AnalysisAssign import Assign as Application
File “/home/nmrware/ccpnmr_new/ccpnmr3.1.0/src/python/ccpn/AnalysisAssign/”, line 30, in
from ccpn.framework.Framework import Framework
File “/home/nmrware/ccpnmr_new/ccpnmr3.1.0/src/python/ccpn/framework/”, line 102, in
from ccpn.ui.gui.Gui import Gui
File “/home/nmrware/ccpnmr_new/ccpnmr3.1.0/src/python/ccpn/ui/gui/”, line 49, in
from ccpn.ui.gui.popups.RegisterPopup import RegisterPopup, NewTermsConditionsPopup
File “/home/nmrware/ccpnmr_new/ccpnmr3.1.0/src/python/ccpn/ui/gui/popups/”, line 38, in
from ccpn.ui.gui.widgets.CheckBox import CheckBox
File “/home/nmrware/ccpnmr_new/ccpnmr3.1.0/src/python/ccpn/ui/gui/widgets/”, line 34, in
from ccpn.ui.gui.widgets.Widget import Widget
File “/home/nmrware/ccpnmr_new/ccpnmr3.1.0/src/python/ccpn/ui/gui/widgets/”, line 37, in
from ccpn.ui.gui.widgets.ScrollArea import ScrollArea
File “/home/nmrware/ccpnmr_new/ccpnmr3.1.0/src/python/ccpn/ui/gui/widgets/”, line 31, in
from ccpn.ui.gui.lib.OpenGL.CcpnOpenGLDefs import BOTTOMAXIS
File “/home/nmrware/ccpnmr_new/ccpnmr3.1.0/src/python/ccpn/ui/gui/lib/OpenGL/”, line 44, in
from OpenGL import GL, GLU, GLUT
File “/home/nmrware/ccpnmr_new/ccpnmr3.1.0/miniconda/lib/python3.8/site-packages/OpenGL/GLUT/”, line 5, in
from OpenGL.GLUT.fonts import *
File “/home/nmrware/ccpnmr_new/ccpnmr3.1.0/miniconda/lib/python3.8/site-packages/OpenGL/GLUT/”, line 20, in
p = platform.getGLUTFontPointer( name )
File “/home/nmrware/ccpnmr_new/ccpnmr3.1.0/miniconda/lib/python3.8/site-packages/OpenGL/platform/”, line 350, in getGLUTFontPointer
raise NotImplementedError(
NotImplementedError: Platform does not define a GLUT font retrieval function

“freeglut” is already installed.
I saw a similar thread on Ubuntu system. There it has been suggested that “echo $PYOPENGL_PLATFORM” and “export PYOPENGL_PLATFORM=egl”. May I know where I should do it.

Try these commands in the terminal that you are running assign from before you start assign. The syntax shown is for the bash shell - if you’re using a different shell you need a different syntax for setting the variable (e.g. for csh/tcsh it would be “setenv PYOPENGL_PLATFORM egl”).

Thanks, Bosmith. I am using “csh”. I have tried that. But I am still getting the same error.


if you install the latest updates and then try running the program hopefully this issue should be resolved now. You can install the updates without actually running the program by running the update program in the /bin directory.

Basically, we aren’t actually using GLUT at all, so we’ve now removed all references to it and the program should therefore not be looking for it on your computer any more.


Thanks, Vicky. It worked perfectly.