Peak list go to position

Hi everyone,

I`m currently working on 2.5.0 version of CcpNmr on a WSL Ubuntu 18.04 LTS.

One of the useful thing I was using which is the `Go To Position` tab on the `Peak: Peak List` window is now strangely only displaying `None`, while it was filled with all dimensions of all my spectra before.
I didn`t change much on the spectra list, just added some HSQC from relaxation measurements and now it doesn`t work anymore, and I don`t know why.
All the fields seems to be correctly filled, they worked perfectly fine like this before (Structure `none` shouldn`t be a problem)


I can still navigate when a peak is selected with `right-click, navigate to` but I`m more interested in the Strip Location function, which is very useful but not working because I cannot select the correct spectrum anymore.

Do you have any ideas how to change those selections? I tried to delete relaxation-HSQC but it didn`t change anything. Reloading to an older save fixed the problem, so it seems to be related to the addition of the new spectra.



One way I found to make it work again is to delete all unecessary spectra and windows, reboot the computer and somehow it work again.

Hi JC,

we`ve been trying this out, but find the behaviour to be that it shows `None` only the very first time you open the Peak List pop-up in a single session. As soon as you select a peak, the Window options are shown and remain available regardless of how many times you close ore reopen the peak list pop-up. (So it is nearly as if this little drop-down needs initialising the first time it used).

Hope this helps,