Pick and Assign module not launching


I’m working with the V3.1.1 software on Mac Catalina doing a backbone assignment. The program was working then stopped and installed a list of updates. When I relaunched AnalysisAssign and tried to open the Pick and Assign module, the following error popped up:

ImportError: cannot import name ‘PeakList’ from ‘ccpn.ui.gui.lib’ (/Users/mecook/nmr/ccpnmr3.1.1/src/python/ccpn/ui/gui/lib/init.py)

Any help with sorting this out would be appreciated!


Hi M.E.

I believe Ed has sorted this one, there were some problems with imports… Could you apply the latest updates and it should go away. If not please let us know as soon as possible with any errors the program gives


I fear the latest Updates might cause a different issue with the Pick & Assign module (see Restricted Pick not working), but we are looking into that one at the moment and will post a fix as soon as we can.


The fix can now be applied via updates, so hopefully your Pick & Assign should be all fine and happy again. Let us know if not.



The fix seems to have worked! I’m able to launch the pick and assign module without any issues.