Potential graphics bug for Analysis v3 on Windows

Hi,

I think that there might a graphics related bug for the Windows installation of Analysis 3.0.4. Essentially, sometimes when I run Analysis suddenly the screen becomes black and I have to hard reboot machine before getting the display back. This happens only occasionally but only when I run Analysis. I have not found any way of getting the display back other than rebooting (e.g. reloading graphics driver with shortcuts does not help). I am pretty sure that everything besides the display works because I can save the project.
I am running Windows 11 Enterprise (21H2 build 22000.593). As far as I can tell Analysis is using Intel UHD Graphics P630 (driver 27.20.100.9664; I also have also Nvidia Quadro RTX 5000 - any idea how I can force the system to force to use this graphics card instead, I know how to do that for regular apps but not something that I have to use a bat file for).
I tried to look at the logs but I cannot find anything specific. Any advice on how to debug to hunt down the exact nature of the problem would be appreciated (I understand that at the moment I am not giving you much to go on about).

Thanks,
Józef

Hi Józef,

Windows installations are always much less reliable than Linux or Mac and can be quite dependent on the individual setup. I haven’t looked at this systematically, but my impression is that we might be seeing a number of people with Windows 11 Enterprise having problems of various kinds. Our Windows machine runs Windows 10 and that is what we compile on. Anyway, I’ll get @ejb on the case - he can hopefully help you further on the graphics card/debugging front.

Vicky

Thanks, Vicky. @ejb - I just had a screen going black then recovering. As far as I can tell from the output in the terminal this is what happened during that time:
“INFO : Validating Project integrity… (Project._getAPIObjectsStatus:960)”
Does that help? Does it do anything related to graphics while validating project integrity?
Sadly about a minute after the screen recovered from being black I got BSOD with:
“Stop code is: SYSTEM_THREAD_EXCEPTION_NOT_HANDLED
What failed: RtsPer.sys”

It looks like we might have to build a separate Windows 11 conda environment in order to get this working reliably on Windows 11. We’ll see if we can persuade IT to give us a machine for this.
Vicky

Hi Vicky,

Just as an update. A bunch of Windows updates later it seems to have gotten better. I have not had a blue screen of death in a while. This suggests that the problem was/is related to a specific driver. I do still get occasional freezes of the graphics but in about last two weeks when I have been using assign a lot of time I have not had the black screen issue even a single time.

A quick question. What is the best way to report bugs/weird behaviours? This forum?

Thanks,
Józef

Hi Józef,

that’s good to hear and suggests that perhaps some of the issues were on the Windows/Driver side. We’re still hoping to procure a new Windows computer soon, so we can have both a Windows10 and Windows11 machine for testing and creating builds.

You can report things either here on the forum or e-mail us direct at support@ccpn.ac.uk. The advantage of the forum is that others will also get to see the issues and solutions (if there is one!).

Vicky