Problems with Python and Assign 3.2.2


This is more of a python problem but maybe you’ll have suggestions on how to fix it.
I somehow messed up my python environment and cannot get it back. I tried to uninstall all the versions of python, anaconda etc. and reinstall. But the problem persists.

When I try to open assign 3.2.2 (but it actually does not matter which version I try) I get a bunch of errors:
Traceback (most recent call last):
File “C:\Program Files\ccpnmr\miniconda\lib\”, line 196, in run_module_as_main
return run_code(code, main_globals, None,
File “C:\Program Files\ccpnmr\miniconda\lib\”, line 86, in run_code
exec(code, run_globals)
File "C:\Program Files\ccpnmr\src\python\ccpn\AnalysisAssign_main
.py", line 32, in
from ccpn.AnalysisAssign.AnalysisAssign import Assign as Application
File “C:\Program Files\ccpnmr\src\python\ccpn\AnalysisAssign\”, line 30, in
from ccpn.framework.Framework import Framework
File “C:\Program Files\ccpnmr\src\python\ccpn\framework\”, line 74, in
from ccpn.core.IntegralList import IntegralList
File "C:\Program Files\ccpnmr\src\python\ccpn\core_init
.py", line 335, in
from ccpn.core.Spectrum import Spectrum
File “C:\Program Files\ccpnmr\src\python\ccpn\core\”, line 95, in
from ccpn.core.lib.SpectrumDataSources.Hdf5SpectrumDataSource import Hdf5SpectrumDataSource
File “C:\Program Files\ccpnmr\src\python\ccpn\core\lib\SpectrumDataSources\”, line 40, in
import h5py
File "C:\Program Files\ccpnmr\miniconda\lib\site-packages\h5py_init
.py", line 25, in
from . import _errors
ImportError: DLL load failed while importing _errors: The specified module could not be found.

I thought assign runs in its own conda environment and that it should matter if I mess up something with my system wide python configuration but it clearly does.

If you have any suggestions on what to try to fix that, I would be greatful.


Hi Jozef

ccpn comes with its own embedded python distribution, I think it is that that’s broken.

In your case this is in ccpnmr\miniconda\

If you redownload the ccpn distribution and install a new copy hopefully that should sort it…


Thanks, Gary. That is what I thought as well but alas, this is not the case.
I have tried redownloading. I tried Win 10 version as well (I am on Win 11). I forgot to mention that my older versions also stopped working.
This is something really weird. I uninstalled everything. I removed variables related to python. I tried to use another account in case this is account specific. The result is the same.
It is really annoying because this means I cannot use assign on my machine with most resources…
I’ll keep trying but if anyone has any suggestions, please, let me know.

Hi Jozef

I had a talk with Ed Brooksbank our main software developer and he has seen this before. The problem appears to be window defender is zeroing out some file during installation because it thinks they are dubious [obviously they are not…] please try installing again with windows defender switched off


Not you should only turn it off temporarily during installation

instructions are here


Thanks, Gary. I will give it a go.

Hi Gary,

I have disabled Windows Defender and still no luck. I can run assign under WSL but it has its own problems there (I get frequent segmentation faults).
I guess I have to go back to virtual machines but it is a bit annoying.


P.S. It is running no problem on another Win 11 machine I have but that is not as powerful as the one with the problem.

I’m sorry about that, Józef. Windows antivirus programs have been getting in the way of things for a few others, too. We’re going to have a look into how we can package things differently, but it doesn’t look like there is an entirely obvious solution.

The other thing to check may be whether the antivirus has put any of the files from the .zip into quarantine. There should be a way of removing a folder from the quarantining process. So that might be something else to look into on that front. I think it is during the extraction of the .zip that this occurs, so you probably have to exclude the parent directory or something like that.