QT error on Ubuntu 20.04


I`m running Ubuntu 20.04
I`m getting this error when I start assign:

QT error: 3
QT error: <PyQt5.QtCore.QMessageLogContext object at 0x7fef13a83190>
QT error: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, minimal, minimalegl, offscreen, vnc, xcb, linuxfb, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, webgl.

Fatal Python error: Aborted

Current thread 0x00007fef8a9a7740 (most recent call first):
  File `/home/jo/software/ccpnmr3.0.4/src/python/ccpn/ui/gui/widgets/Application.py`, line 35 in __init__
  File `/home/jo/software/ccpnmr3.0.4/src/python/ccpn/ui/gui/Gui.py`, line 123 in _initQtApp
  File `/home/jo/software/ccpnmr3.0.4/src/python/ccpn/ui/gui/Gui.py`, line 103 in __init__
  File `/home/jo/software/ccpnmr3.0.4/src/python/ccpn/framework/Framework.py`, line 556 in _getUI
  File `/home/jo/software/ccpnmr3.0.4/src/python/ccpn/framework/Framework.py`, line 384 in __init__
  File `/home/jo/software/ccpnmr3.0.4/src/python/ccpn/AnalysisAssign/AnalysisAssign.py`, line 39 in __init__
  File `/home/jo/software/ccpnmr3.0.4/src/python/ccpn/AnalysisAssign/__main__.py`, line 47 in <module>
  File `/home/jo/software/ccpnmr3.0.4/miniconda/lib/python3.8/runpy.py`, line 86 in _run_code
  File `/home/jo/software/ccpnmr3.0.4/miniconda/lib/python3.8/runpy.py`, line 193 in _run_module_as_main
/home/jo/software/ccpnmr3.0.4/bin/assign: line 8: 1896059 Aborted                 (core dumped) `${CONDA}`/bin/python -W ignore `${ANALYSIS}` $*

I have the required libraries.
Has anyone else had this issue? 


Hi Jo,

not entirely sure what is going on here, but given that our Ubuntu build was done on Ubuntu 16.04, it could be that the environment it provides is simply too old and we`ll need to do a new build for it to work on 20.04. We`ll investigate.

Best wishes,

Hmm, this seems to run on our Ubuntu20.04.3 without any issues...
Is it worth trying to download and unpack again? Perhaps something got corrupted during the process?


Hi Vicky,

I think it may be a problem with an Ubuntu update, it would seem that I can`t run any other v3 versions either but I could previously. I`m downloading 3.0.4 again and I`ll see whether that helps in any case...


Hi Vicky,

So reinstalling 3.0.4 and also the ubuntu qt5 installation didn`t work. Is it possible for me to compile analysis from scratch? 


Hi Jo,

sorry to hear you are having issues running 3.0.4
I have attached a .zip containing the scripts required to install/compile the dependencies.

Download the scripts.zip to your 3.0.4 folder ~/software/ccpnmr3.0.4 and unzip.
It should add a folder called Internal

from a terminal, navigate into the folder with

cd internal/scripts

There are a list of bash scripts in here. The main one you need is installMiniconda.sh

The environment we use is called Miniconda which supplies the specific python and its dependencies.
To run the script, type


and follow the questions.
It will ask to download and install miniconda3 to your home directory as ~/miniconda3
and then create the environment by downloading the required files.

There will be a series of questions:

Do you want to download/install the latest Miniconda?

answer y, or n if you already have the ~/miniconda3 folder

Do you wish the installer to prepend the Miniconda install
location to PATH in your ~/.bash-profile?

answer y the first time (you can run the script as many times as needed) to add ~/miniconda3/bin to your PATH

Do you want to install a new environment?

answer y the first time, or if you want to replace it. answer n if you only want to change the symbolic link (the next step)
This will create ~/miniconda3/envs/ccpn-v3.0.4 which is the python environment.

Do you want to create symbolic link?

answer y to replace the miniconda folder in the AnalysisV3 folder to point to the new environment folder above,
in your case ~/software/ccpnmr3.0.4/miniconda

Before following the last step below, check if the program is working with the new environment, open a new terminal, and run


Finally, if the above step has worked, from the internal/scripts folder again, run


to compile the last bits of C code, I have not fully checked this last step on Ubuntu 20.04 yet though

Sorry this seems long, but hopefully that describes the steps you need
Kindest regards


Hi Ed,

Thanks for your help, the instructions worked fine. However, I was still getting the same error. But subsequently removing pyqt and reinstalling it has done the trick, assign is now running.