Save project and Format converter

Hi there,

I have some issues with V2. 

A- When I try to save my project, the following error occurred: UnicodeEncodeError: `ascii` codec can`t encode character u`\xed` in position 19: ordinal not in range(128).

B- The Format Converter does not work, only show in the window: `select option from menu`

I hope you can help me, thanks a lot!!!

Hi Alejandro,

That looks to me as though somewhere in the project you used a non-ASCII character - probably a letter with an accent or umlaut. If there is a traceback in your terminal window, that might show you whether this was the project name you chose, or something you named within the project.

I wonder if you are using V2.5.2 on a Mac? I get the same window pop up as you describe, but basically when that window is selected, the Mac menu right at the top of the screen changes to to the Format Converter menu and I can open a project or create a new one and then start doing things.

Hope this helps,


Hi Vicky,
Thanks for your help!

B) I am using V2.5.2 on a Windows. I tried in the 2.4 version and there, the Format Converter works.
A) I just created an empty project named a, and the same error occurred:

start generating output : memops.Implementation.MemopsRoot
Exception working on topObject <memops.Implementation.MemopsRoot id:193317192>, file C:/Users/miott/Desktop/a/memops/Implementation/a.xml
Exception in Tkinter callback
Traceback (most recent call last):
File `C:\Users\miott\Documents\ccpnmr2.5.2Windows\ccpnmr2.5.2\miniconda\lib\lib-tk\`, line 1547, in __call__
return self.func(*args)
File `C:\Users\miott\Documents\ccpnmr2.5.2Windows\ccpnmr2.5.2\ccpnmr2.5\python\memops\editor\`, line 164, in save
File `C:\Users\miott\Documents\ccpnmr2.5.2Windows\ccpnmr2.5.2\ccpnmr2.5\python\memops\general\`, line 425, in saveProject
File `C:\Users\miott\Documents\ccpnmr2.5.2Windows\ccpnmr2.5.2\ccpnmr2.5\python\memops\api\`, line 18297, in save
File `C:\Users\miott\Documents\ccpnmr2.5.2Windows\ccpnmr2.5.2\ccpnmr2.5\python\memops\api\`, line 18362, in saveTo, self)
File `C:\Users\miott\Documents\ccpnmr2.5.2Windows\ccpnmr2.5.2\ccpnmr2.5\python\memops\format\xml\`, line 178, in save
saveToStream(stream, topObject, mapping, comment, simplified, compact)
File `C:\Users\miott\Documents\ccpnmr2.5.2Windows\ccpnmr2.5.2\ccpnmr2.5\python\memops\format\xml\`, line 193, in saveToStream
simplified, compact, expanded)
File `C:\Users\miott\Documents\ccpnmr2.5.2Windows\ccpnmr2.5.2\ccpnmr2.5\python\memops\xml\`, line 4598, in saveToStream
UnicodeEncodeError: `ascii` codec can`t encode character u`\xed` in position 19: ordinal not in range(128)