Structure Tutorial March 2023 - Questions


I am trying to learn how to use CcpNmr for structure calculation, so I am following the “Solving structures from NMR data” tutorial and have a few questions :

First, in step 3 “Structure Calculation Setup”, do we only need the noesy PeaklLists and the chemical shift list, or do we also need to complete the assignment of Noesy peaks like described in step 2B ?
Also, is a n-noesy spectra enough or is a c-noesy necessary ?

Second, in step 4 “Importing results”, I tried to do everything starting from the provided file “structure_2.ccpn/data/xplor_nih”. Unfortunately, after the processing of the Xplor-NIH calculations with CcpNmr (4A) and when trying to inspect the results using PyMol (4B) I wasn’t able to obtain the same results as when using the data provided in “structure_2.ccpn/data/xplor_nih.done/run-1-2022-11-22-205018.done/fold”. In fact, the file ensemble.pdb in folder “fold” obtained after step 4A is empty. Is it expected because I didn’t provide enough data or am I missing something ?
I haven’t checked every file created by the processing, but apart from ensemble.pdb they look similar to the one in “structure_2.ccpn/data/xplor_nih.done/run-1-2022-11-22-205018.done”.

Finally, it is not perfectly clear for me when TalosN is used. Is it implicitly when running Xplor-NIH ?

I apologize if my questions are very basic, I’m not quite familiar with these new concepts and never used Xplor-NIH before.

Many thanks in advance,


Hi Theodore,

Thanks for getting in touch.

To answer your questions:

  1. You only need a chemical shift list and NOESY peak list, you do not need to assign NOESY peaks, as the current version of Xplor NIH generates peak assignments. We included a part about assigning NOESY peaks as for some software packages it may be beneficial to use them in structure calculations (for instance in Aria Web development server). You can only use one spectra.

  2. This is definitely expected that those files should be generated - I presume you have Xplor NIH installed on your computer and have its path set up in Preferences?

  3. TalosN run is set as the first step of the Xplor NIH calculation, we are working to make it “independent”.

Please let me know if you have any other questions.

Best wishes,

Hi Eliza,

Thank you very much for your answer ! Things are a bit clearer now.
For the issue with the processing of Xplor-NIH structure calculation results, I didn’t install the program with the right binary (Darwin and not Darwin_arm64, because I’m on a Mac), but now it works perfectly !

I still have a few questions. I wanted to try “Setting up and running Xplor-NIH” (step 3B) now that I have all the programs working, but unfortunately, when I run the shell script it doesn’t give me the same amount of files as the one in the provided “run-1-2022-11-22-205018”. When looking in the terminal, it seems I have two main issues (I might be wrong):
First, I have these two lines pretty early in the calculation : " Can’t open file for reading
env: pyXplor: No such file or directory". I tried different things, but as I am not really used to these environments, I didn’t manage to solve anything.
Despite these messages the calculation still continues, until running where I get: "FileNotFoundError: [Errno 2] No such file or directory: ‘input_new.nef’ ". Same happens with and, and then the calculation stops (without running ?). Again, I tried to look for the origin of the problem but I struggled and didn’t find anything.

Do you know a way of fixing these issues ? I hope my explanations are understandable.

Again, many thanks in advance,


Hi Eliza,

I continued working on trying to solve my issues and seem to have made some small improvements:
I found that my second issue, the lack of ‘input_new.nef’ file, was related to my first issue, because, that creates this ‘input_new.nef’, uses, that requires the pyXplor environnement. Thus, I added pyXplor in my path and I managed to get rid of the first issue ! Unfortunately, the ‘input_new.nef’ Is still not generated because of a new issue (when running I guess ?) : ‘Can’t open file /Users/theodorebellon/opt/talosn/tab/ for reading’.

I’ll try to find a way to solve this new issue, but if you have any ideas I’ll be more than grateful !

I hope again that my explanations are understandable and that my way of fixing the previous problem was correct.

Best wishes,


Hi Eliza,

I tried different unorthodox options in order to fix my issues, but I believe I never managed to solve them completely. For the last issue I mentioned, I couldn’t get rid of the error message “Can’t open file /Users/theodorebellon/opt/talosn/tab/ for reading”, but by copying and pasting the different pred*.tab files in my directory I manage to make at least part of the programs work, especially and This attempt is still running ( and indeed take a lot of time to complete), but I can already see that the calculations aren’t /won’t be done correctly, most probably because my poor fixes.

I thus decided to try to do the calculations on nmrBox, where the different programs (pyMol, Xplor-NIH and TalosN) should be properly installed. This time, as expected, it seems that I didn’t receive any error message when first running But when reaching the execution of (step 5 in the no files are being generated (unlike when running the poorly fixed program on my computer, which managed to generated a lot of pass2_*.pdb files). The program has been running for a few hours now and no new files have been generated since a long time (last generated file, named xplor.log.55912.39, has been created 2h30 ago). Is that normal ?

Sorry for all my questions and my struggle.

Have a nice day,


Dear Theodore,

First apologies for late reply, for whatever reason I did not get your latest replies to my email. Sorry about this!

Xplor NIH / Talos issues on your machine:

  1. pyXplor error - when you install Xplor NIH you may need to run configure with an optional -symlinks argument. Instructions are in INSTALL file in the unpacked Xplor NIH directory.

  2. Shell script ( is written in the way that even if the previous step was not successful it will still run, but will give you an errors, for instance it will complain that expected file is not in the directory.

  3. I also found that Mac M1 (is that what you have?) is not entirely compatible with running multi CPU calculations.

NMRBox - in principle everything is installed and should run nicely with all those CPUs… - but we had another user reporting that calculations are actually very slow.
I would very much like to investigate that issue with NMRBox and a few examples of your log files would be helpful, could you send those to

Please get in touch via support email and we can try to sort out your issues.
Kindest regards,