Ubuntu22.04 and ccp3.1.0


I have installed ccp3.1.0 on my new updated Ubuntu system 22.04.
Unfortunately, when I start ccpnmr3.1.0/bin/assign, i have an error message
The error message concern Glut font.
File “/home/simorre/Software/ccpnmr3.1.0/src/python/ccpn/ui/gui/lib/OpenGL/init.py”, line 44, in
from OpenGL import GL, GLU, GLUT
File “/home/simorre/Software/ccpnmr3.1.0/miniconda/lib/python3.8/site-packages/OpenGL/GLUT/init.py”, line 5, in
from OpenGL.GLUT.fonts import *
File “/home/simorre/Software/ccpnmr3.1.0/miniconda/lib/python3.8/site-packages/OpenGL/GLUT/fonts.py”, line 20, in
p = platform.getGLUTFontPointer( name )
File “/home/simorre/Software/ccpnmr3.1.0/miniconda/lib/python3.8/site-packages/OpenGL/platform/baseplatform.py”, line 350, in getGLUTFontPointer
raise NotImplementedError(
NotImplementedError: Platform does not define a GLUT font retrieval function

Any idea to help me ?

Perhaps glut is not installed on your system? Try

sudo apt-get install freeglut3

in a terminal.

Thanks for the idea but Glut was already installed.
Reading package lists… Done Building dependency tree… Done Reading state information… Done
freeglut3 is already the newest version (2.8.1-6).
0 to upgrade, 0 to newly install, 0 to remove and 2 not to upgrade.
I still have the same error message with ccpnmr3.1.0

That would have been too easy! Maybe try


and if it is not set, set it with


in the shell that you run assign from.

Still too easy :) Platform is already set to egl …
echo $PYOPENGL_PLATFORM answers egl

Hi JP,

it looks like we are going to have try and make a dedicated Ubuntu 22.04 release. We’ll try and get that done over the coming week.

Best wishes,


have you tried export PYOPENGL_PLATFORM=osmesa ?

it may not work as fast but it may work, of course it may not as well…

from https://github.com/MPI-IS/mesh/issues/49


other possible values are posix and clx

nice and thank you ! ccpnm3.1.0 start on ubuntu22.04 with PYOPENGL_PLATFORM=posix !

BUT now ccpnmr3.1 shows the same problem as other ccp versions 3 on ubuntu22.04. I can’t get the spectrum display. The display module freezes while everything was working in Ubuntu18.

Software blocks after the message in the terminal :

and then nothing happens

Note that at the start of the program, I have this type of message

"libGL error: MESA-LOADER: failed to open iris: /usr/lib/dri/iris_dri.so: cannot open shared object file: No such file or directory (search paths /usr/lib/x86_64-linux-gnu/dri:$${ORIGIN}/dri:/usr/lib/dri, suffix _dri)
libGL error: failed to load driver: iris
libGL error: MESA-LOADER: failed to open swrast: /usr/lib/dri/swrast_dri.so: cannot open shared object file: No such file or directory (search paths /usr/lib/x86_64-linux-gnu/dri:$${ORIGIN}/dri:/usr/lib/dri, suffix _dri)
libGL error: failed to load driver: swrast

I have checked, but libgl-gist is correctly installed.
Maybe Vicky if you have time to design a dedicated Ubuntu 22 version , I will wait for this version.

Cheers and thanks to both of you for your help

Hi JP,

the Ubuntu 22 Version is now available at https://www.ccpn.ac.uk/download/3.1.0/ccpnmr3.1.0Ubuntu22.04Academic.zip

Hopefully this will work for you now.


Hi vicky,

This is great ! I am out of town and without my Linux machine. I will try friday to install your version and I will let you know if it works.
Adrien Favier will also try since he was waiting for this version to upgrade his system.
Thanks a lot for your help !