Unable to print NMR spectra.

Whenever I try to print NMR file, it shows “no such directory”, even when I create the directories.

I’m struggling to recreate this.
Which version of the program and what operating system are you using?
How are you selecting the file and path for printing? Are you typing them in the box or using the little folder button and selecting them interactively?
Are you using particular options when printing, or is this even with all the default settings and printing to pdf?

this comes when I give the command ctrl+P on any spectra which is open. I use ccpn3.1, analysis assign, to load and assign my spectra. I don’t get any option to select the path for download, its default.

ubuntu is operating system.

I think I’ve seen this before - it’s not to do with where you’re trying to output the file but rather some software library in the printing toolchain is trying to save a record of your prefered fonts.

Try (in a terminal)

mkdir ~/.fonts

and then try printing again. If it doesn’t work straight away, save, close & reopen assign and try again.

I tried making a directory, but everytime the same happens and sometimes the name of the directory also changes in the error notification

An update was added to the server on Wednesday which should hopefully have solved this problem.