V3 keeps crashing when I load tutorial demo spectra


I recently downloaded the Windows 10 beta version of the CCPNmr V3 software, and I am having issues with loading spectra. For some reason, when I run assign/analysis, and try to load the hsqc.spc spectrum (the Beginners` tutorial demo spectrum), the program crashes.

Has anyone else seen this glitch occurring?

Joshua C

Hi Joshua,

sorry we never got back to you on this. Things were rather manic around conference time!

We`ve had a couple of other people get in touch with the same issue, but can`t seem to recreate it ourselves. It sounds a bit like a threading issue that we had already fixed. Are you sure you are all up to date with the latest updates (Help / Check for Updates)?

All the best,


Hi Vicky,

Thank you for your response! I checked for updates and it seems up to date so far, yet loading spectra files from the tutorial data still causes crashes. Is it possibly because I`m using the Windows version of CCPNmr package?

Kind regards,
Joshua Chandanani

Hi Joshua,

yes, this certainly seems to be a Windows-specific thing though we can`t seem to re-create it on our Windows machine. We did find a few errors related to dragging spectra into the drop area (though they weren`t causing a crash for us). We`ve fixed those issues and posted some updates on the update server. So have a go with those and let us know how you get on.

Thanks and best wishes,


Hi VickyH and team
After sifted through the available posts on this, I am reaching out since with a similar problem of Assign v3. not working as expected on Windows 10. Will give a quik bullet list of what’s been done and what’s observed so far :

  • I could install without issues (i.e. unzipping etc. worked fine).

  • Updates went through OK.

  • Restart did bring up the GUI as expcted.

  • But, when I open a spectrum, I am getting an OpenGL related error, followed by several errors.

  • Command shell point to several exceptions.

I tested with a generic data set but I also am able to reproduce the behavior, when I simply imported the CSP project Tstart.ccpn.

  • I have a Surface laptop at home running Windows 11 and I didn’t see any issues running Assign on that.

I am uploading some screenshots that hopefully will help in troubleshooting. I am including the Windows 10 version info. page for reference.

Thank you very much.


it’s hard to work out exactly what is going on here. Windows is particularly sensitive to individual setups. From what you say it sounds as though opening any spectrum is a problem. So there is clearly some issue related to the OpenGL installation on this particular computer. One of colleagues observed that it is running Windows 10 Enterprise and wondered if that perhaps has a different OpenGL installation to other Windows versions?

Hi Vicky and team
Sorry for the late reply. I am presently continuing with my working version on Fedora lInux platform. The primary reason to try out Windows was to do a remote demo session using Zoom of from Windows. I had problems with my zoom session on my Fedora box. I don’t have much low level familiarity with Windows vis-a-vis Graphics display problems and will reach out to my IT support and see what I can find. If I succeed, I will post a follow up note. Thank you for taking the time.


Vicky and team
My Windows IT guru points out that it could be a graphics driver problem on my PC. The box is not that new i.e. Dell Optiplex 390. The best I could do was to update a Dell provided driver that is ca. 2013 (!) and that didn’t fix the OpenGL issue either.
The alternative that my IT buddy suggested is to put a fairly new PCI graphics card instead of the one from the mother board. Do you guys have any recommendations on that ? I just want to avoid ending up with a card that doesn’t solve the problem, if at all possible.

Thank you for the kind help.


Pretty much any OpenGL capable graphics card should be OK, but I have had better luck with NVidia based cards than ATi ones. My goto cards for my LINUX boxes have been the low end Quadro (P400, P620, etc.) cards. This is almost certainly overkill for your purpose, but would leave you with a card you could reuse when you skip the Optiplex :slight_smile: