V3 License


Will there be an updated license available to run the current version of Analysis? The current license expires on May 28th (today). I was trying to open up the program and would get the following error message:

ERROR: Analysis-V3 version number `3.0.b5` has expired on Tue May 28 11:04:30 2019

Aborting program


Hi Domarin.

Have you tried to run the updates?
change to bin and run ./update

I am pretty sure the version online expires the 2nd Jul. Soon will be a new release with new features and bug fixes.


Hi Luca!

I just ran the update command in bin and I am getting the message `No updates for installation.` I also checked on the CCPN website before the original post and the license file available is also until May 28th.

Hi Domarin,

Ed has just put a new licence on the update server, so hopefully you should now be able to download that and be okay.
Sorry for the delay,


Awesome! Thank you! I actually had an email this morning suggesting to download the license file again because the text on the website may have just been incorrect and that seemed to have worked perfectly.

I do seem to have a separate problem from opening my data file. I was working on a file and wanted to work off of my last save point, so I went into the project menu under open recent to open the last saved file. That is when the program stopped working due to the licensing issue. I figured I would be able to open it after fixing it this morning but instead I was getting a message indicating there was a fatal error and it would open from the last save point. Instead, the project file is unable to completely open and I am worried I am unable to access the data entirely. I tried to open the backup file only to get the same result. I started a fresh project file and managed to have recreated the problem, but fortunately was able to access the backup file to open up the program without issues. I am not sure if this is something useful to look at but I have included the terminal message I was getting into this post.

Thank you again for all your help!

==> Loading CCPN project `/home/dkhago/Documents/gp78C_spectra/gp78C.ccpn`
INFO : Closing /tmp/CcpnProject_yv3v36sz.ccpn/default (Logging._info:109)
Error loading file for: <ccp.nmr.Nmr.NmrProject [`default`]>
Reading: <_io.TextIOWrapper name=`/home/dkhago/Documents/gp78C_spectra/gp78C.ccpn/ccpnv3/ccp/nmr/Nmr/default+default_user_2019-04-30-10-43-07-530_00001.xml` mode=`r` encoding=`UTF-8`>
Last xml tag read: _StorageUnit
Parser state was: checking validity
Object stack was empty


I cannot use CCPN V3 because of a licence issue:

I tried bin/update with the following output:

ERROR: Analysis-V3 version number `3.0.0` has expired on Tue Mar  3 11:43:10 2020
Aborting program

Thank you for your help,


Hi Adrien,

sorry about this - we should have seen this one coming. You can now download a licence file from the website:

Best wishes,

Hi Vicky,

It works, thank you very much,


Hi Vicky,

Our versions of ccp3.0.X expired on Wed Sep 2

Can you help us?

Best wishes


Hi Adrien,

looks like you must be working with an old version. Currently the latest version is 3.0.2 - see our downloads page:

We highly recommend that you keep up to date, as we post bug fixes and new features on a regular basis (it`s the main reason why we currently tend to have licences that expire - that forces users to update to the latest version ;) ).

Best wishes,