Where can I find the licence for 3.0.3.

As probably many out there I figured out that my licence does not work any more. There is a nice video tutorial showing how one can update the software:

But: this works only BEFORE the licence expires, because after that date I cannot open CCPN3 any more.

On the download page (https://www.ccpn.ac.uk/v3-software/downloads) I do not find v 3.0.3.

Can someone please tell me where to find either the licence file only, or the whole new version?


Hi Paul,

we`ve not done the build for v3.0.3 yet. Updating to v3.0.3 does in fact already update the licence file, but it looks like the problem might be at our end with the way the licence is checked (this is the first time we did an update of the version as part of the update mechanism - anyone who updated before 9 Jan was fine, but for some reason updates after expiry is causing an issue). We`re looking into this at the moment.

On the plus side, I think we have finally managed to persuade the boss to do away with these expiring licences. So this should hopefully be the last time this happens!

Best wishes,


I should have added: in principle you can always update after a licence has expired by running ./update from the bin directory. But I think unfortunately, due to the version update this is not sufficient this time round.

Thanks, Vicky.

I am in favor of not having expiring licences any more :-)

Do you have a rough estimate when I can get the 3.0.3. program? Will it be on the download website?


Actually, running ./update from the bin directory worked, i.e. I can use 3.0.2 now. That`s good enough for now! Thanks.

You can either update from the /bin or download and replace the licenceKey.txt located in the /config directory.
Download from http://www.ccpn.ac.uk/download/3.0.2/licenceKey.txt.zip

This should be the last licence update regarding an expiring date.
From now on, non-profit licences will be effectively unlimited.

A 3.0.3 version of the OSX launcher is also available for download from https://www.ccpn.ac.uk/v3-software/downl...-downloads

^ Thank you... worked on Windows