Windows ccpnmr2.5.2 crashing

I have a student working on Windows 10 using ccpnmr2.5.2. Though the tutorial projects will open, any time she tries to open spectra directly ccpnmr crashes. Similarly, anytime she tries to go to spectral properties ccpnmr crashes. Any advice? Thank you!!


thanks for reporting this. We don`t use Windows much ourselves, so we tend to be less aware of the problems on Windows. We`ll have a look to see if we can work out what is going on and get back to you.

Could you let us know what type of spectra she is trying to load (Bruker, NmrPipe, ucsf etc.)? It could be an issue with a certain file type.



Thank you so much! So far we have tried the spectra from the tutorials and our own NmrPipe spectra with the same effect. Have not tried directly from Bruker yet. Thanks again!


sorry it has taken a while to get back to you.

It looks as though this is an issue linked to the way in which you start the program. So if you start it by double-clicking on the analysis.bat file, then Windows opens a default shell in which to run the program. But it seems you end up with this problem that means as soon as you move your mouse through a spectrum, the program crashes. This is likely some kind of threading issue which would be quite hard to unpick.

A work-around is to open the program from a shell that you open yourself. So click the Start button, then go to Windows System and then Command Prompt. This will open a shell for you.
(If you have it installed/available on your system, you can also start a Windows Powershell, instead.)
You then have to go to the bat directory with e.g.
cd release2.5.2\ccpnmr2.5.2\bat
depending on where you have installed the program.
Finally, type
to start the program.

This workaround has been successful for us, hopefully it will work for you as well.

Best wishes,


Thank you so much for looking into this! I`m sorry for the delay in response as I hadn`t met with my student the past couple of weeks. We just tried this out today. Using both windows powershell and command prompt the program opens just fine. We get through the commit and choice of experiment type but once again when we hit open ccpnmr just crashes. This was true for the spectra in the tutorials and our own spectra from NMRPipe. If you have any other suggestions that would be fantastic. Thank you again for all of your help!

Are you able to send us any error messages / tracebacks from the shell? That might help us trace what is going on.



Hi Vicky,

Here is the output in the terminal that it prints before crashing -- after crashing there is no error printed.

Spectrum successfully opened
finished opening spectrum Expt_1 182.spc
GL_RENDERER = Intel® UHD Graphics
GL_VERSION = 4.6.0 - Build

Thank you again for your help with this!!